Parchea ya tu Linux si usas aplicaciones Snap: la última vulnerabilidad detectada facilita al atacante lograr privilegios de root

Parchea ya tu Linux si usas aplicaciones Snap: la última vulnerabilidad detectada facilita al atacante lograr privilegios de root
11 comentarios

A mediados de la pasada década, Canonical (la compañía desarrolladora de Ubuntu Linux) puso en marcha su propia iniciativa para distribuir paquetes de software para Linux independientes de la distribución. Así, los paquetes Snap vinieron a sumarse a otros formatos 'universales', como Flatpak y AppImage.

Si ya en los primeros pasos del formato, hace 6 años, se detectaron graves problemas de seguridad con los Snaps, que permitía a sus desarrolladores robar datos de otras aplicaciones, ahora han salido a la luz múltiples vulnerabilidades nuevas de este sistema de empaquetado de software…

…siendo el caso más crítico, la clasificada como CVE-2021-44731, una vulnerabilidad que puede ser explotada para realizar un ataque de escalada de privilegios, obteniendo así privilegios de 'root' (el usuario administrador en los sistemas Unix).

Un vistazo a…
LINUX y GNU: LINUX: QUÉ ES y CÓMO FUNCIONA

Inyecciones de código (ya parcheadas)

Este problema de seguridad, con una puntuación de gravedad de 7,8 en el sistema CVSS, está localizado en el programa snapd (el que permite instalar, actualizar y desinstalar los paquetes Snap), concretamente en el componente snap-confine, encargado de construir el entorno de ejecución de las aplicaciones.

Aparentemente, según informa Red Hat, este componente presenta lo que se conoce como una 'condición de carrera', la situación que se produce cuando la secuencia de eventos de un proceso no se ejecuta en el orden que el programador esperaba, generando así errores.

El proceso afectado sería la preparación del 'espacio de nombres' privado del Snap, lo que abre la posibilidad de inyectar código arbitrario. Bharat Jogi, director de investigación de vulnerabilidades y amenazas en Qualys, explica que

"La explotación exitosa de esta vulnerabilidad permite a cualquier usuario sin privilegios obtener privilegios de root en el host vulnerable y [podría ser utilizada apra] obtener privilegios de root completos en instalaciones predeterminadas de Ubuntu".

Y si bien esta vulnerabilidad no puede ser explotada de manera remota, cualquier atacante que haya iniciado sesión como usuario sin privilegios puede explotar 'rápidamente' el error para obtener los permisos de administración.

Además, la firma de ciberseguridad descubrió otras seis vulnerabilidades:

  • CVE-2021-3995 ? Desmontaje no autorizado en libmount de util-linux.
  • CVE-2021-3996 ? Desmontaje no autorizado en libmount de util-linux.
  • CVE-2021-3997 ? Recursividad no controlada en los archivos systemd-tmp de systemd.
  • CVE-2021-3998 ? devolución de valor inesperado de realpath() de glibc.
  • CVE-2021-3999 ? Desbordamiento/desbordamiento de búfer off-by-one en getcwd() de glibc.
  • CVE-2021-44730 ? Ataque Hardlink en sc_open_snapd_tool() de snap-confine.

Todas estas vulnerabilidades fueron parcheadas ayer por el equipo de seguridad de Ubuntu (te recomendamos actualizar lo antes posible si haces uso de este software), tras habérsele sido notificada su existencia a finales del pasado mes de octubre.

Vía | The Hacker News

Temas
Comentarios cerrados
Inicio