Publicidad

Hola jQuery 2.0, adiós old-IE

Hola jQuery 2.0, adiós old-IE
Sin comentarios

Publicidad

Otra cosa no pero no se puede negar que la gente de jQuery es currante, no paran de sacar nuevas versiones y refinar su ya de por si muy potente y sencillo de utilizar framework. Esta vez le toca el turno a la versión 2.0, que lleva disponible desde hace un par de días y que cuenta como mayor hecho diferenciador el haber retirado el soporte para los old-IE (es decir, Internet Explorer 6-7-8).

Esta retirada de soporte a los navegadores más vetustos de Microsoft ha supuesto una reducción del tamaño del código en un 12% por lo que hace a esta nueva versión de jQuery ideal para su inclusión en aplicaciones móviles (PhoneGap, Blackberry 10, Firefox OS), extensiones de navegadores o aplicaciones para Windows 8. Para aplicaciones web que requieran soporte para un amplio espectro de navegadores recomiendan seguir usando jQuery 1.x y anuncian la próxima salida de jQuery 1.10.

También recomiendan que si usas una versión antigua de jQuery, migres primero a la versión 1.9 y luego, de que compruebes que todo funciona como un reloj suizo, pasar a la 2.0 ya que son API-equivalentes (sea lo que sea lo que eso signifique).

¿Y cuáles serán los siguientes pasos en esta rama 2.x recién estrenada? Pues al parecer se quieren centrar en seguir aligerando el tamaño del código y su próximo objetivo serán los parches para las versiones antiguas de Webkit y Android. Veremos a ver que tal.

Pues nada, después del tochazo que os he metido como si nada, toca ponerse el mono de trabajo, equiparnos de snacks chocolateados y bebidas energéticas y ponernos a trastear, que es lo que nos gusta.

Pd: todos los commits de esta versión, son unos pocos, ¿verdad?

Vía | Official jQuery Blog

Temas

Publicidad

Comentarios cerrados

Publicidad

Publicidad

Inicio
Compartir